故障现象:
在尝试安装 Windows Update 中的一个更新后,系统提示您重新安装此更新。
原因分析:
如果此更新第一次未正确安装,或者 Windows Update 设置无法检测到此更新,则可能会发生这种情况。
解决方案:
Windows 8
重置 Windows Update 组件,然后尝试更新计算机。
若要自动重置 Windows Update 组件,请单击“Fix it”按钮或链接。单击“文件下载”对话框中的“运行”,然后执行“Fix it”向导中的步骤。
注意此 Fix it 解决方案有两个模式:默认模式和攻击性模式。您应该先运行默认模式的 Fix it 解决方案,并确定此模式是否可以解决 Windows Update 中出现的问题,然后再运行攻击性模式。
注意此向导可能只提供英文版本。但是,Windows 的其他语言版本也提供自动修复功能。
注意如果您当前操作的计算机未出现此问题,则可将 Fix it 解决方案保存到闪存驱动器或 CD 或 DVD 中,然后在出现此问题的计算机上运行此解决方案。
有关如何重置 Windows Update 组件的详细信息,请访问以下 Microsoft 网站:
如何重置 Windows Update 组件:https://support.microsoft.com/kb/971058/zh-cn#method24
如果 Windows Update 仍再次提供同一更新,请转到“确定是否已安装更新”部分。然后,使用“解决问题”部分中的一种方法。
确定是否已安装此更新
若要查看是否已安装此更新,请使用下面的方法。
查看安装历史记录
要查看安装历史记录,请执行以下步骤:
1、从屏幕右边缘滑入或按 Windows + C 键,然后点按或单击“搜索”个性分类;
2、在搜索中,键入 Windows Update。点按或单击“设置”;
3、点按或单击“查看更新历史记录”;
4、找到特定更新的最新条目;
5、如果“状态”列中的条目显示为“成功”,则表明此更新已安装。如果“状态”列中的条目显示为“待定”,则表明此更新未安装。
如果未安装更新,则如何解决此问题
如果更新网站中的更新旁显示红色图标或错误消息,请访问下面的 Microsoft 网站,了解有关如何解决此问题的详细信息:
如何解决 Windows Update、Microsoft Update 和 Windows Server Update Services 的安装问题:
https://support.microsoft.com/kb/906602/zh-cn#method24
如果已安装更新,则如何解决此问题:
方法 1:使用 Microsoft 安全扫描程序扫描计算机中的病毒和恶意软件。
若要使用 Microsoft 安全扫描程序扫描计算机,请单击以下链接:
https://www.microsoft.com/security/scanner/zh-cn/
方法 2:使用反间谍软件扫描计算机。
使用反间谍软件和防病毒软件扫描计算机。
若要查看第三方防病毒软件提供商的列表,请访问:
https://www.microsoft.com/windows/antivirus-partners/windows-7.aspx
Windows 7
重置 Windows Update 组件,然后尝试更新计算机。
要自动重置 Windows Update 组件,请单击“Fix it”按钮或链接。在“文件下载”对话框中单击“运行”,然后按照 Fix it 向导中的步骤执行操作。
注意此 Fix it 解决方案有两个模式:默认模式和攻击性模式。您应该先运行默认模式的 Fix it 解决方案,并确定此模式是否可以解决 Windows Update 中出现的问题,然后再运行攻击性模式。
注意此向导可能只提供英文版本。但是,Windows 的其他语言版本也提供自动修复功能。
注意如果您当前操作的计算机未出现此问题,则可将 Fix it 解决方案保存到闪存驱动器或 CD 或 DVD 中,然后在出现此问题的计算机上运行此解决方案。
有关如何重置 Windows Update 组件的详细信息,请访问以下 Microsoft 网站:
如何重置 Windows Update 组件:https://support.microsoft.com/kb/971058/zh-cn#method24
如果 Windows Update 仍再次提供同一更新,请转到“确定是否已安装更新”部分。然后,使用“解决问题”部分中的一种方法。
确定是否已安装此更新
若要查看是否已安装更新,请使用下列方法之一。
方法 1:查看安装历史记录
要查看安装历史记录,请执行以下步骤:
1、单击“开始”,指向“所有程序”,然后单击“Windows Update”或“Microsoft Update”;
2、单击“查看更新历史记录”;
3、找到特定更新的最新条目;
4、如果“状态”列中的条目显示为“成功”,则表明此更新已安装。如果“状态”列中的条目显示为“待定”,则表明此更新未安装。
方法 2:检查安装日志文件
注意
此方法只适用于 Windows 更新。Office 更新不会创建此日志文件。
您必须知道此更新对应的知识库 (KB) 文章编号。如果不知道要尝试安装的更新的 KB 编号,您可以在 Windows Update 的可供安装更新列表中查看此编号。
获取 KB 编号后,依次单击“开始”和“运行”,键入 %Windir%\\KBnnnnnn.log,然后按 Enter。
注意在此命令中,nnnnnn 代表关于更新的知识库文章编号。
如果日志文件中出现类似下例的条目,则表明更新已安装。
注意在此示例条目中,x 表示一个数值。
RebootNecessary = x,WizardInput = x, DontReboot = x, ForceRestart = x
如果未安装更新,则如何解决此问题
如果更新网站中的更新旁显示红色图标或错误消息,请访问下面的 Microsoft 网站,了解有关如何解决此问题的详细信息:
如何解决 Windows Update、Microsoft Update 和 Windows Server Update Services 的安装问题:
https://support.microsoft.com/kb/906602/zh-cn#method24
如果已安装更新,则如何解决此问题
方法 1:使用 Microsoft 安全扫描程序扫描计算机中的病毒和恶意软件若要使用 Microsoft 安全扫描程序扫描计算机,请单击以下链接:
https://www.microsoft.com/security/scanner/zh-cn/
方法 2:使用反间谍软件扫描计算机
使用反间谍软件和防病毒软件扫描计算机。
若要查看第三方防病毒软件提供商的列表,请访问:
https://www.microsoft.com/windows/antivirus-partners/windows-7.aspx
若要下载并安装 Microsoft Security Essentials 防病毒软件,请访问:
https://www.microsoft.com/en-us/security_essentials/default.aspxc